adriano gilardone Docente di Statistica Matematica Excel Spss sfruttare excel consulenze statistiche lezione videocorsi

blog

blog

Funzione CONTA SE di Excel: guida completa

YouTube video
Postato il 8 Luglio 2024
Tag

Filtrare e analizzare dati in base a specifiche condizioni può essere un processo lungo e ad alto rischio di errore. A meno che tu non impari a padroneggiare la funzione CONTA SE di Excel.

In questo articolo chiarisco come si usa la CONTA SE, quando usare CONTA PIÙ SE e ti svelo perché, a volte, non funziona.

corso excel

Cosa è la funzione CONTA SE e come si utilizza?

La funzione CONTA SE è uno degli strumenti più versatili di Excel per chi lavora con grandi set di dati e necessita di effettuare analisi condizionali.

Questa funzione consente agli utenti di contare il numero di celle che soddisfano un criterio specifico all'interno di un determinato intervallo, facilitando l'analisi dei dati e la generazione di report dettagliati.

La sintassi base della funzione è:

conta se

Gli argomenti della funzione CONTA SE

Gli argomenti principali di questa funzione sono due.

Intervallo

Il range di celle su cui applicare il criterio. Questo può essere una singola colonna, una riga o un blocco di celle selezionate.

Criterio

Il criterio specifico che le celle devono soddisfare per essere contate. Può essere espresso come un numero, un'espressione, o una stringa di testo che rappresenta una condizione logica (ad esempio, ">30", "<100", "=70", ">=10").

Esempio pratico

Vuoi contare quanti clienti hanno acquistato il prodotto "Finestra X".

Hai a disposizione un foglio Excel con un elenco di vendite nel quale ogni riga rappresenta un acquisto effettuato da un cliente. 

Nella colonna A hai il nome del cliente.

Nella colonna B è elencato il prodotto acquistato.

Per calcolare il totale delle vendite di "Finestra X", puoi utilizzare la funzione CONTA SE seguendo questi passi:

Seleziona la cella 

In base a dove desideri visualizzare il risultato.

Inserisci la formula

= CONTA.SE(B1:B6;"Finestra X")

Questa formula controlla l'intervallo dalla cella B1 alla B100 per trovare tutte le occorrenze del prodotto "Finestra X". Ogni volta che trova una corrispondenza, incrementa il conteggio. 

Premi Enter

Il risultato sarà visualizzato nella cella selezionata.

Il risultato finale sarà il numero totale di clienti che hanno acquistato "Finestra X" nell'intervallo specificato.

corso excel

I criteri che puoi impostare nella CONTA SE

La funzione CONTA SE di Excel è estremamente versatile e permette di utilizzare una varietà di criteri per contare le celle che soddisfano determinate condizioni. 

Vediamo i più comuni.

Dati numerici specifici

Puoi specificare un numero esatto come criterio. 

Esempio:

=CONTA.SE(A1:A100;10) 

conta quante volte il numero 10 appare nell'intervallo A1:A100.

Intervalli di numeri

Puoi utilizzare operatori come > (maggiore di), < (minore di), >= (maggiore o uguale a), e <= (minore o uguale a) per contare le celle che soddisfano queste condizioni numeriche. 

Esempio:

=CONTA.SE(A1:A100;">=50")

conta tutte le celle che hanno un valore maggiore o uguale a 50.

Testi esatti

Per i criteri testuali, inserisci il testo tra doppi apici. 

Esempio:

=CONTA.SE(B1:B100;"Mela") 

conta tutte le celle che contengono esattamente la parola "Mela".

Criteri testuali con wildcards

Puoi usare i caratteri jolly come ? (che sostituisce un singolo carattere) e * (che sostituisce una sequenza di caratteri) per criteri più flessibili

Esempio:

=CONTA.SE(B1:B100;"Mela*") 

conta tutte le celle che iniziano con "Mela" (come "Melanzana", "Melanoma", ecc.).

Date

Le date possono essere usate come criteri inserendole tra doppi apici e formattandole in modo coerente con le impostazioni del sistema o del foglio di calcolo. 

Esempio:

=CONTA.SE(C1:C100;"01/01/2020") 

conta tutte le celle con la data 1 gennaio 2020.

Formule o espressioni

Puoi anche usare espressioni o riferimenti a celle come parte del criterio.

Esempio:

=CONTA.SE(D1:D100;A1) 

conta tutte le celle in D1:D100 che corrispondono al valore presente in A1.

A cose serve la funzione CONTA PIÙ SE?

La funzione CONTA.PIÙ.SE in Excel è un'estensione della CONTA SE che permette di applicare più condizioni contemporaneamente per contare le celle. 

La sua sintassi è:

conta più se

Gli argomenti della funzione CONTA PIÙ SE

Gli argomenti possono essere molteplici. Ti spiego i principali.

Intervallo_criteri1

È il primo intervallo di celle su cui viene applicato il primo criterio. Questo intervallo viene esaminato per verificare quali celle soddisfano il criterio specificato.

Criterio1

È la condizione che deve essere soddisfatta nel primo intervallo di celle per che la cella sia conteggiata. Il criterio può essere un numero, un'espressione, o una stringa di testo che specifica la condizione da soddisfare.

[intervallo_criteri2, criterio2, ...]

Questi sono argomenti opzionali che permettono di aggiungere ulteriori condizioni. Ogni intervallo_criteri aggiuntivo specifica un nuovo gruppo di celle da esaminare in base a un nuovo criterio.

Puoi aggiungere quanti criteri vuoi.

Vantaggi

Analisi multidimensionale

CONTA.PIÙ.SE permette di valutare più variabili contemporaneamente

Ad esempio, se un manager vuole sapere quanti dipendenti in specifici dipartimenti hanno superato un certo livello di performance, può utilizzare questa funzione per ottenere il conteggio senza dover segmentare i dati manualmente.

Risparmio di tempo e automatizzazione

Utilizzando CONTA.PIÙ.SE, è possibile automatizzare compiti che altrimenti richiederebbero l'uso di filtri manuali o la creazione di tabelle pivot. 

Questo risparmia tempo e riduce il rischio di errori umani durante il processo di analisi dei dati.

Flessibilità nei report

Questa funzione offre una flessibilità notevole nei report, permettendo agli utenti di modificare i criteri senza dover riscrivere o riorganizzare le formule esistenti. 

Ciò facilita l'adattamento dei report a nuove domande analitiche o cambiamenti nei dati.

Condizioni complesse

Con CONTA.PIÙ.SE, è possibile includere condizioni logiche più complesse, come combinazioni di diversi criteri. 

Ad esempio, potresti voler contare il numero di vendite che superano un certo valore in specifiche regioni durante un determinato periodo promozionale.

corso excel

Esempio pratico

Hai un foglio di calcolo che traccia le vendite di prodotti in diverse regioni e vuoi sapere quante vendite hanno superato i 1000 euro nel Nord durante il mese di dicembre

I dati sono così distribuiti:

  • A1:A100 contiene le regioni
  • B1:B100 contiene gli importi delle vendite, 
  • C1:C100 contiene le date delle vendite. 

La formula potrebbe essere qualcosa come:

=CONTA.PIÙ.SE(A1:A100,"Nord",B1:B100,">1000",C1:C100,"12/2020")

La funzione verifica tutte e tre le condizioni contemporaneamente e restituisce il numero di vendite che soddisfano tutti i criteri specificati.

Una soluzione per ogni errore comune 

Quando si lavora con la funzione CONTA SE in Excel, è possibile incorrere in vari errori. 

Vediamo i più comuni e come risolverli.

Errore #VALORE!

Causa

Questo errore si verifica quando il criterio fornito non è compatibile con i dati presenti nell'intervallo specificato. 

Ad esempio, se il criterio è un numero ma l'intervallo contiene del testo.

Soluzione

Assicurati che il criterio sia coerente con il tipo di dati nell'intervallo. Se stai cercando di utilizzare un numero come criterio, verifica che l'intervallo non contenga testo.

Errore #NOME?

Causa 

Questo errore appare quando Excel non riconosce la formula inserita, spesso a causa di un errore di digitazione o di sintassi nella formula.

Soluzione

Controlla che la funzione sia digitata correttamente, in particolare assicurati che sia "CONTA.SE" e non una variante errata. Verifica anche che non ci siano spazi o caratteri non necessari nella formula.

Criteri non riconosciuti

Causa

A volte i criteri specificati in CONTA SE non vengono riconosciuti correttamente a causa di problemi di formattazione, come spazi extra o uso errato di virgolette per criteri di testo.

Soluzione

Rimuovi spazi extra e assicurati che i criteri di testo siano correttamente racchiusi tra virgolette. Ad esempio, "Caffè" anziché Caffè.

Riferimenti di cella errati

Causa

Gli errori di riferimento si verificano quando le celle incluse nella formula sono state eliminate o spostate.

Soluzione

Rivedi i riferimenti nella formula per assicurarti che puntino alle celle corrette. Aggiorna i riferimenti se le celle sono state modificate o sostituite.

Conteggio errato

Causa

A volte, la funzione CONTA SE può restituire un conteggio errato se le condizioni o i criteri sono impostati in modo improprio.

Soluzione

Verifica i criteri per assicurarti che corrispondano esattamente a ciò che intendi analizzare. Controlla che non ci siano incongruenze o errori logici.

Esempio pratico

Vuoi contare il numero di dipendenti in un elenco che hanno un'età superiore a 30 anni. La formula corretta sarebbe:

=CONTA.SE(B2:B100,">30")

Se invece ricevi un errore, controlla che:

  • Non ci siano spazi dopo il simbolo > nel criterio.
  • L'intervallo B2:B100 non contenga errori di formattazione, come celle formattate come testo anziché numeri.
corso excel

Riassumendo

  • La funzione CONTA SE di Excel è uno strumento che permette di contare le celle che soddisfano un determinato criterio all’interno di un dato intervallo.
  • La formula base è =CONTA.SE(intervallo; criterio).
  • Utilizza CONTA.PIÙ.SE per includere più condizioni nel calcolo, estendendo la flessibilità della funzione CONTA SE.

Ripetizioni private

Ho intrapreso una interessante collaborazione con il sito di TROVAPROF.IT

Questa start-up mette in relazione studenti che cercano lezioni private con professori di qualsiasi materia. Se stai cercano delle ripetizioni per le materie che non tratto io, allora ti consiglio di fare un salto su TROVAPROF.IT, un portale completamente gratuito per dare o ricevere lezioni private.

Iscriviti alla Newsletter

Se hai bisogno d’informazioni che non hai trovato nella sezione servizi o dei video corsi, scrivimi un messaggio o chiamami.
Domande, prezzi, richieste, delucidazioni...tutto quello che ti serve. Cercherò di risponderti entro le 24h.
Newsletter

Consenso al trattamento dei dati
Utilizzerò i tuoi dati (nome ed indirizzo mail) solo per inviarti gratuitamente via mail la newsletter mensile. Niente spam, niente scocciature, ti disiscrivi in un click quando vuoi.

linkedin facebook pinterest youtube rss twitter instagram facebook-blank rss-blank linkedin-blank pinterest youtube twitter instagram